Problem with the ECC Spanish translation

Posts that are done/fixed/closed or aged! for this section are placed in here to keep the forum in shape & more viewable!
User avatar
Jarlaxe
ECC Support
Posts: 96
Joined: 29 Aug 2008, 19:12
Location: Barcelona, Spain

Problem with the ECC Spanish translation

Unread post by Jarlaxe » 05 Jun 2009, 14:31

Hi friends!

I'm working on the ECC Spanish translation.


I got include my language accents saving the text in UFT-8 format, but I can't show correctly this characters:
char1.png
char1.png (2.85 KiB) Viewed 1223 times
Is impossible to make a correct translation of this words:
char2.png
char2.png (3.24 KiB) Viewed 1223 times
ECC does not support this characters? :?

Any possible solution? [-o<

Thanks!

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9057
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Problem with the ECC Spanish translation

Unread post by Phoenix » 05 Jun 2009, 16:19

Hi Jarlaxe,

1. please attatch images to a post ;-) (this prevents dead links after a while)
2. can you post translation files here?, so we can take a look at it to find the problem.

Thanks!
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Jarlaxe
ECC Support
Posts: 96
Joined: 29 Aug 2008, 19:12
Location: Barcelona, Spain

Re: Problem with the ECC Spanish translation

Unread post by Jarlaxe » 05 Jun 2009, 19:39

One example...
1.png
2.png

The files: (translated i18n_meta.php only)
ECC Spanish translation.zip
(26.08 KiB) Downloaded 21 times
Thanks phoenix!

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9057
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Problem with the ECC Spanish translation

Unread post by Phoenix » 05 Jun 2009, 23:56

Hi Jarlaxe,

Thanks, i'll take a look at it

(p.s. you can also attatch zip files ect. ;))
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Jarlaxe
ECC Support
Posts: 96
Joined: 29 Aug 2008, 19:12
Location: Barcelona, Spain

Re: Problem with the ECC Spanish translation

Unread post by Jarlaxe » 06 Jun 2009, 00:06

Phoenix wrote:Hi Jarlaxe,

Thanks, i'll take a look at it

(p.s. you can also attatch zip files ect. ;))

Upppps! jejeje. Sorry sorryyy :lol:

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9057
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Problem with the ECC Spanish translation

Unread post by Phoenix » 06 Jun 2009, 00:08

Hi Jarlaxe,

I found it:
es_01.jpg
This is how you should do the Spanish translation :detective:

1. Save your files in UTF-8 format (not ANSI.....some languages need to be saved in UTF-8 and other in ANSI)
es_02.png
2. Change in charset.ini the 'encoding_destination' to: iso-8859-1
es_03.png
es_03.png (25.16 KiB) Viewed 1209 times
That should do the trick ;)
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Jarlaxe
ECC Support
Posts: 96
Joined: 29 Aug 2008, 19:12
Location: Barcelona, Spain

Re: Problem with the ECC Spanish translation

Unread post by Jarlaxe » 08 Jun 2009, 09:22

Hi Phoenix!

I need your help please!

I followed your instructions (save the files in UTF-8 format, and change charset.ini to iso-8859-1)

But continues to show bad characters.
1a.png
1a.png (22.37 KiB) Viewed 1192 times
I have tested on two different computers (with Windows Vista 32bits and Windows Xp)

You can look at this file and tell me that I do wrong?

Please, if this file is wrong, you can return the corrected file?

Thanks for your patience!
es.zip
(25.34 KiB) Downloaded 25 times

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9057
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Problem with the ECC Spanish translation

Unread post by Phoenix » 08 Jun 2009, 10:34

HI Jarlaxe,

Are you using v1.0.0 WIP? (this translation will not work on ECC 0.9.9).

Please install 1.0.0 WIP ;) and try again
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Jarlaxe
ECC Support
Posts: 96
Joined: 29 Aug 2008, 19:12
Location: Barcelona, Spain

Re: Problem with the ECC Spanish translation

Unread post by Jarlaxe » 08 Jun 2009, 12:21

Great Phoenix! You are the best! =D>

Problem solved. I was using version 0.9.9

I see that some things have changed in the new version. I will start from the beginning to translate. :D

One last thing ...

What is the exact function of this button?
2a.png
I tried it, but I can not see its function. I know to translate it properly.

Very very thanks! :thumbsup:

User avatar
DerMicha75
ECC2 (java) Developer
Posts: 521
Joined: 05 Feb 2007, 22:14
Location: Germany
Contact:

Re: Problem with the ECC Spanish translation

Unread post by DerMicha75 » 08 Jun 2009, 20:47

Hi,

The button changes the behaviour of displaying images in the game list. You choose "Ingame title" and in the list ingame title pictures appear. But when you have a game without such a pic, an other (title or so) is shown. So the list keeps colored...

If you pressed the button it stays in. And only ingame title pictures appear. If a game has no such pic, the placeholder pics shows up. So the label "match" is used to show "only show pictures that exacly MATCHES the setting"

Micha

User avatar
Jarlaxe
ECC Support
Posts: 96
Joined: 29 Aug 2008, 19:12
Location: Barcelona, Spain

Re: Problem with the ECC Spanish translation

Unread post by Jarlaxe » 08 Jun 2009, 22:14

Ummmmm, I see ... Now I understand :-k

Excellent explanation Micha. =D>

Thanks friend!

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9057
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Problem with the ECC Spanish translation

Unread post by Phoenix » 08 Jun 2009, 22:57

Closing...
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest