Can't start emuControlCenter "ECC (1004)"

Posts that are done/fixed/closed or aged! for this section are placed in here to keep the forum in shape & more viewable!
argony
Posts: 7
Joined: 23 Aug 2008, 19:59
Location: Germany, Wörth Am Rhein
Contact:

Can't start emuControlCenter "ECC (1004)"

Unread post by argony » 23 Aug 2008, 20:31

I've Installed ECC and after creating these image's or what it was itwill start the programm and the error apears. ECC (1004)
I've tried it with the new WIP 01 version 0.9.9 too, doesn't changed something.

Code: Select all

[23-Aug-2008 21:41:33] PHP Fatal error:  Uncaught exception 'SQLiteException' with message 'SQLiteDatabase::__construct(): malformed database schema - unable to open a temporary database file for storing temporary tables' in E:\Emulator\Neuer Ordner\ecc-system\manager\cDbmsSqlite2.php:31
Stack trace:
#0 E:\Emulator\Neuer Ordner\ecc-system\manager\cDbmsSqlite2.php(31): SQLiteDatabase->__construct('database/eccdb', '0666', 'malformed datab...')
#1 E:\Emulator\Neuer Ordner\ecc-system\ecc.php(718): DbmsSqlite2->connect()
#2 E:\Emulator\Neuer Ordner\ecc-system\ecc.php(7788): App->__construct()
#3 {main}
  thrown in E:\Emulator\Neuer Ordner\ecc-system\manager\cDbmsSqlite2.php on line 31

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 23 Aug 2008, 22:08

Hi argony,

It seems like an corrupt/broken database... :-k

Can you ZIP the DB?, and attatch here please (if too big, use an filesharerer like rapidshare/megaupload ect.)

Andreas, is there any way to fix it (and to prevent this)?
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
ECC
ECC Founder & Developer 2005-2009
Posts: 3680
Joined: 28 Aug 2006, 11:58
Location: Hamburg, Germany
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by ECC » 23 Aug 2008, 22:23

Hm, strange... never seen a broken database. Have you already data in your database? Maybe i can repair it. Otherwise please copy the database/eccdb.empty to your database/ folder and remove your corrupt one. Rename the eccdb.emtpy to eccdb
ECC Developer 2005-2009
http://www.camya.com/ecc/
contact: ecc@camya.com

argony
Posts: 7
Joined: 23 Aug 2008, 19:59
Location: Germany, Wörth Am Rhein
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by argony » 24 Aug 2008, 00:47

I Don't have any Data's in my Database, i've copied and renamed eccdb but nothing changed.

I've never seen the Content of emuControlCenter (tried to start - ECC could not start-up! :(, closing...).
I am new here and installed it one or 2 day's before, but it doesn't work ^^.

I've attached the BugReport.htm . I Hope someone can find the problem. :boxing:

*******************
What must i Do when i starting ECC the first time?
Must i add a Emulator or some Roms or something ?
*******************
I'm using Windows XP SP3 - German

2x2,66 Ghz Intel E6750
4 GB Ram
Nvidia GeForce 8800 GTX
DVD-RW, 5.1 Headset,
Razer Lachesis(Mouse), Keyboard (Logitech), 2.1 Sound, 19" (1440x900) TFT Monitor
------------
Here my Specs if it helps, i dont think so, but better as nothing ^^ :smartass:
Attachments
eccBugreport.rar
ECC Bug-Report HTM
(4.06 KiB) Downloaded 40 times

User avatar
ECC
ECC Founder & Developer 2005-2009
Posts: 3680
Joined: 28 Aug 2006, 11:58
Location: Hamburg, Germany
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by ECC » 24 Aug 2008, 01:00

Can you again install the 0.9.8b in a different folder and start this version? Is your E: drive a harddrive?

- Install 0.9.8b
- start this version
- do nothing, just close.
- restart

Is this working?
ECC Developer 2005-2009
http://www.camya.com/ecc/
contact: ecc@camya.com

argony
Posts: 7
Joined: 23 Aug 2008, 19:59
Location: Germany, Wörth Am Rhein
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by argony » 24 Aug 2008, 12:34

I've Installed 9.8b first to "C:" and after it i've tried the rar version in "E:", both are harddrive's...
I'm trying now installing 9.8b to "E:".

It's creating the userfolder with images...
*Update*
It's finished with Installing, the same again:

Code: Select all

[24-Aug-2008 13:39:48] PHP Fatal error:  Uncaught exception 'SQLiteException' with message 'SQLiteDatabase::__construct(): malformed database schema - unable to open a temporary database file for storing temporary tables' in E:\Emulator\emuControlCenter\ecc-system\manager\cDbmsSqlite2.php:31
Stack trace:
#0 E:\Emulator\emuControlCenter\ecc-system\manager\cDbmsSqlite2.php(31): SQLiteDatabase->__construct('database/eccdb', '0666', 'malformed datab...')
#1 E:\Emulator\emuControlCenter\ecc-system\ecc.php(718): DbmsSqlite2->connect()
#2 E:\Emulator\emuControlCenter\ecc-system\ecc.php(7739): App->__construct()
#3 {main}
  thrown in E:\Emulator\emuControlCenter\ecc-system\manager\cDbmsSqlite2.php on line 31

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 24 Aug 2008, 13:11

Hi argony,

I tested the INSTALLER 2 times on 2 different systems, all works!

1) Installed 0.9.8b.
2) Updated ECC.
3) Started ECC and added roms.

I'll try the RAR version now...

Can you run eccBugreport and ZIP the HTM file, and attatch it to this topic?, so we can examine it... :detective:
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 24 Aug 2008, 13:22

I also tested the RAR file, again no problems... :-k the eccdb.empty in the INSTALLER and RAR package is the same...

@Agony
Can you try the installer version, and see if that works?
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

argony
Posts: 7
Joined: 23 Aug 2008, 19:59
Location: Germany, Wörth Am Rhein
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by argony » 25 Aug 2008, 13:31

I've used the Installer Version at first, can't start...
After it I used therar, can't start...
I've Updated it, can't start, WIP used, the same again

Kann das sein das ews was mit dem PHP zutun hatt? ist ja immerhin ein Error der auf php hinweist :D.
Muss ich irgendetwas spezielles Installiert haben oder läuft ECC auf jeden Windoof (ClearInstall)?

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 25 Aug 2008, 17:34

After some searching...it's not an ECC problem! :detective:

Are you running VISTA?...it seems you don't have rights to the TEMP folder :?
From google, seen it is a problem of SQLlite. The user I use to run
apache have access right to tmp directory.
source: http://osdir.com/ml/version-control.sub ... 00130.html
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 25 Aug 2008, 17:40

Or maybe you have other server software installed?

http://www.christian-web-masters.com/fo ... opic=10434
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

argony
Posts: 7
Joined: 23 Aug 2008, 19:59
Location: Germany, Wörth Am Rhein
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by argony » 25 Aug 2008, 19:00

I've running Win XP 32.
How can i change the Temp Folder in windows? maybe this could fix the problem.

which server software must i use? atm. i'm using nothing, just a FTP-Client Filezilla, but that's not the problem

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 25 Aug 2008, 19:30

argony wrote:which server software must i use
Microsoft IIS?


Are you an admin on that system?
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 25 Aug 2008, 19:37

Hmmm. does this error occur on all platforms when importing roms?

@Andreas
Maybe you hailed the DB wrong??

Code: Select all

 think, at last I've traced the problem:

One of the scripts doesn't make use out of database contents at all. But at
the beginning there was a simple check for database file presence, just to
let the user know, if there (from any reason) could be dbfile missing:

if ($dbhandle = sqlite_open("/path/to/database/dbfile.db", 0666, $sqliteerror)) 
{
  $result = sqlite_unbuffered_query($dbhandle, 'select something from 
some_table');
  sqlite_close($dbhandle);
} else {
  die($sqliteerror);
}


Yes, the "$result = ..." line can be omitted (it is now, anyway...), because
a successfull opening a database file is enough to check, whether the file
is present, or not (although without SELECT it may be any other database
file, with quite different tables).

My problem was caused by the fact, that there was a "SELECT" query, but
$result handle hasn't been processed any further. After commenting out the
"$result = ..." line there are no more "persistent" open database connections.


And the question: is it normal behaviour - or is it a bug in PHP-module?
I've got a feeling, that after "sqlite_close($dbhandle)" there should be
assumption, that the script will not use database anymore (until ev. next
"sqlite_open"), so all ev. other handles related to database contents should
be immediately removed.
source: http://www.mail-archive.com/sqlite-user ... 26638.html
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
ECC
ECC Founder & Developer 2005-2009
Posts: 3680
Joined: 28 Aug 2006, 11:58
Location: Hamburg, Germany
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by ECC » 26 Aug 2008, 17:36

No, at my vista system at home all work without a problem. Anybody else use vista here?
ECC Developer 2005-2009
http://www.camya.com/ecc/
contact: ecc@camya.com

User avatar
Vicman
PLATINUM member
Posts: 1233
Joined: 17 Jun 2007, 16:12
Location: Germany,Bochum

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Vicman » 26 Aug 2008, 20:12

sorry, I use XP :no:
imagepacks:
Done: Vic20, N64, Philips VG-5000 G7000 G7400, SordM5, Amstrad GX4000, Enterprise 64/128
Progress: Atari 8bit, Dosbox, Exelvision EXL 100
Vicman's eCC-Clips on You Tube

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by Phoenix » 26 Aug 2008, 20:30

I also don't have Vista...i still think it's a 'permission to write to TEMP' problem... :-k
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
DerMicha75
ECC2 (java) Developer
Posts: 521
Joined: 05 Feb 2007, 22:14
Location: Germany
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by DerMicha75 » 26 Aug 2008, 21:14

Hmmm, he has XP SP3...

argony, please do: (@ all other, ignore my german here :-) just a test if he can write inside his temp foler (if there is one...) )

Start - Ausführen
Tippe "cmd"
In der Konsole dann "set temp"

a.) Versuche bitte ob du in dem Verzeichnis ne Datei speichern kannst
b.) Poste bitte das Ergebnis

Micha

argony
Posts: 7
Joined: 23 Aug 2008, 19:59
Location: Germany, Wörth Am Rhein
Contact:

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by argony » 27 Aug 2008, 00:49

Ja, das verzeichniss das in der Console angegeben wird ist Vorhanden (mit ner menge files drinne ^^ ) und beschreibbar = Ja ich kann ne Datei speicher.
hab da so ne .dat einfach mal mehrfach kopiert und eingefügt :D.


In English - Short:
Yes can save a file to my Temp Dir.

I am Admin, no other Accounts runnning on this PC. Server Software not Installed.

MrX_Cuci
Posts: 97
Joined: 09 Jul 2008, 01:10
Location: The Netherlands

Re: Can't start emuControlCenter "ECC (1004)"

Unread post by MrX_Cuci » 27 Aug 2008, 23:40

I use Vista Ultimate 32 bit, works fine with admin rights

Locked

Who is online

Users browsing this forum: No registered users and 1 guest