ScummVM Script does not find the exe

If you encounter bugs, errors or crashes, please report them in this section so we can try to fix it!
User avatar
DerMicha75
ECC2 (java) Developer
Posts: 521
Joined: 05 Feb 2007, 22:14
Location: Germany
Contact:

ScummVM Script does not find the exe

Unread post by DerMicha75 » 29 Dec 2009, 22:16

Hi, since update XXX (don't know, but it worked in some version before!) I can not run ScummVM games. It says ""c:\ecc...\scummvm.exe" " can not be found. But it is there. I think it is a prob with the double " chars....

same for Sega Saturn (SSF) script.

I have update 421

Micha

btw phoenix, you have a date problem. last updates in log says that they came from 2008, we have now 2009, near 10 :-)

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: ScummVM Script does not find the exe

Unread post by Phoenix » 04 Jan 2010, 18:30

Hi DerMicha75,

1. I have to check the variables in the SCUMMVM script....

2. Sega Saturn (SSF) mounting should be fixed in update 00442 (more info here: http://ecc.phoenixinteractive.nl/viewto ... =27&t=3041)

3. wich logs?, ecc live??, these are your cpu time & date :clown:
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
DerMicha75
ECC2 (java) Developer
Posts: 521
Joined: 05 Feb 2007, 22:14
Location: Germany
Contact:

Re: ScummVM Script does not find the exe

Unread post by DerMicha75 » 04 Jan 2010, 22:23

Hmmmm, I just updated to 422 and it (Sega Saturn) does not work. Now it says first "wrong commandline" (from demon tools lite) and then the old error that ssf.exe could not be found. Where to get the new script?

Micha

PS: The date problem was in the log. Look:

Code: Select all

************************************************************************
29.12.2009 / 22:08:50 ECC LIVE! UPDATE (v3.2.0.3)
************************************************************************
It seems that MY time is ok :-)

Code: Select all

Welcome to ECC Live!, initializing...

initializing:	language...ok!, using 'en' language!
checking:	validations...ok!, all validations passed!
retrieving:	current ECC version 1.0 build 06 (2009.08.08)
retrieving:	current OS type...ok!, running on 'winnt'.
retrieving:	drive letter...found!, running from drive 'C'.
retrieving:	free space on drive 'C'...ok!, free space: 29.882.261.504 bytes.
checking:	writable media...ok!, media is writable.
checking:	internet connection...ok!, found active connection.
retrieving:	user CID...BA032FDC
retrieving:	last installed update...succes!, last update is 00418
setting:		using temp folder 'C:\ECC_Collector\ecc-core\tools'
setting:		master server set to 'http://www.camya.com/ecc/updates/'
querying:		master server...succes!
#########################################
master server message:
Read the FORUM for more info about updates!
http://eccforum.phoenixinteractive.nl
#########################################
action:		log-in...succes!

checking:	updates...succes!, found 3 update(s)!
checking:	ECC still active?...yes.
action:		closing ECC!
retrieving:	DL server list...succes!, found 2 servers.
querying:		DL server #1: 'http://www.camya.com/ecc/updates/'...succes!
setting:		using 'http://www.camya.com/ecc/updates/' for downloading.
checking:	available updates...found!
checking:	update 00419...succes!
downloading:	update 00419 info and instructions...succes!
#########################################
info:		update 00419
os/inst:		update for WinNT (eccMain installation).
size:		7 KB
short info:	ECC script updates
software part:	main
date:		2008.12.18
And yours not :smartass:

Again 2 times later...

Code: Select all

author:		Phoenix
#########################################
checking:	free space for update...ok!
downloading:	update 00419...succes!
notice:		downloaded 7 KB.
action 00419.1:	extracting update files...done!
action:		deleting temporally update 00419 files...done!
checking:	update 00420...succes!
downloading:	update 00420 info and instructions...succes!
#########################################
info:		update 00420
os/inst:		update for WinNT (eccMain installation).
size:		6 KB
short info:	ECC script updates
software part:	main
date:		2008.12.20
author:		Phoenix
#########################################
checking:	free space for update...ok!
downloading:	update 00420...succes!
notice:		downloaded 6 KB.
action 00420.1:	extracting update files...done!
action:		deleting temporally update 00420 files...done!
checking:	update 00421...succes!
downloading:	update 00421 info and instructions...succes!
#########################################
info:		update 00421
os/inst:		update for WinNT (eccMain installation).
size:		1800 KB
short info:	AutoIt v3.3.2.0
software part:	main
date:		2008.12.23
author:		AU3 Team
But 422 looks good again :thumbsup:

Code: Select all

#########################################
info:		update 00422
os/inst:		update for WinNT (eccMain installation).
size:		5 KB
short info:	ECC script updates
software part:	main
date:		2010.01.04

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: ScummVM Script does not find the exe

Unread post by Phoenix » 04 Jan 2010, 22:27

Thanks... i'll watch these dates XD, can you try saturn again with update 000423?
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
DerMicha75
ECC2 (java) Developer
Posts: 521
Joined: 05 Feb 2007, 22:14
Location: Germany
Contact:

Re: ScummVM Script does not find the exe

Unread post by DerMicha75 » 04 Jan 2010, 22:33

Hi phoenix,

not working, same two mesages....

Micha

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: ScummVM Script does not find the exe

Unread post by Phoenix » 04 Jan 2010, 22:39

Hmmm, the messagebox may seem to show double "" but in the code it is not... can you open 'ecc-script\eccScriptDaemonTools.ini' and look at the path, then check if deamontools really exists there (maybe you reinstalled it??), otherwise delete this INI and try saturn again, a window will open to config deamontools again...hope this helps ;)

the scummvm is another thing i have to look at, i'll do this ASAP
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

User avatar
DerMicha75
ECC2 (java) Developer
Posts: 521
Joined: 05 Feb 2007, 22:14
Location: Germany
Contact:

Re: ScummVM Script does not find the exe

Unread post by DerMicha75 » 04 Jan 2010, 22:48

Daemon tools is there :-)

I found the first problem with wrong commandline.

In your eccScriptSystem.au3 you should do 2 things:

replace " -mount 0," with " -mount 0, " (space after comma is needed)

And I just did some chr(34) around the $RomFile, so my file looks like this:

ShellExecuteWait($DaemonTools, " -mount 0, " & chr(34) & $RomFile & chr(34), "")

This works.

Now only message withe double "" appears, and I see, in code this is not. Your $Emulator varible does the " signs and a space after emu. I think AutoIT makes the extra " signs.... so only solution: $Emulator has to be without the " and in all scripts that uses the varible you have to add the space sign...

Micha

User avatar
Phoenix
ECC Developer 2006-2016
Posts: 9059
Joined: 27 Aug 2006, 01:17
Location: Deventer, The Netherlands
Contact:

Re: ScummVM Script does not find the exe

Unread post by Phoenix » 05 Jan 2010, 01:41

DerMicha75 wrote:replace " -mount 0," with " -mount 0, " (space after comma is needed)
OK, i'll fix this in the next update. (i'll also do a small update on the deamontools section)
DerMicha75 wrote:And I just did some chr(34) around the $RomFile, so my file looks like this:
ShellExecuteWait($DaemonTools, " -mount 0, " & chr(34) & $RomFile & chr(34), "")
This works.
No no, please i have made the 'IntelliX' section in eccScriptSystem to let it take over the extra rom settings, so if the option 'escape path' is clicked ecc script will apply this to the variable!, no more Chr(34) needed!

Please make sure you have your option set when running a script now :sorcerer: (more info: http://ecc.phoenixinteractive.nl/viewto ... =28&t=2997)
Sebastiaan Ebeltjes | ECC Developer 2006-2016 | ECC Forum Admin | Phoenix Interactive WebMaster
[- ECC programs -]
eccUpdate, eccScriptSystem, GtkThemeSelect, DatFileUpdater (DFU), ImagePackCenter (IPC), eccDiagnostics, 3dGallery, iccImageInject
eccKameleonCode, eccCreateStartmenuShotcut, eccThirdPartyConfig (TPC), EmuMoviesDownloader (EMD), eccVideoPlayer
MobyGamesImporter (MGI), ECC Amiga GetGemusConfig.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests